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GE2115 COMPUTER PRACTICE LABORATORY – I L T P C
                               0 0 3 2


LIST OF EXERCISE S 

a) Word Processing 15

1. Document creation, Text manipulation with Scientific notations.
2. Table creation, Table formatting and Conversion.
3. Mail merge and Letter preparation.
4. Drawing - flow Chart

b) Spread Sheet 15

5. Chart - Line, XY, Bar and Pie.
6. Formula - formula editor.
7. Spread sheet - inclusion of object, Picture and graphics, protecting the document
and sheet.
8. Sorting and Import / Export features.

imple C Programming * 15

9. Data types, Expression Evaluation, Condition Statements.
10. Arrays
11. Structures and Unions
12. Functions


TOTAL: 45 PERIODS
* For programming exercises Flow chart and pseudocode are essential


HARDWARE / SOFTWARE REQUIRED FOR A BATCH OF 30 STUDENTS
Hardware
LAN System with 33 nodes (OR) Standalone PCs – 33 Nos.
Printers – 3 Nos.

Software
OS – Windows / UNIX Clone
Application Package – Office suite
Compiler – C












Ex.No 1.a

Document creation
Aim :
	To Create an advertisement of a Software Company in word to recruit software professional for four different designations with an attractive page border, name of the company using word art, using at least one clip art, mentioning the company address and number of vacancies
Procedure :
1. To Create a document ,select File menu bar then choose New option
2. Choose Borders and Shading option from the Format menu. It displays Borders and  
       Shading dialog box .   
3. Click on Page Border tab and choose the Page Style from the style drop down list then page border is added to the document.
4. For Themes, select Format, then go to Themes & select any themes from the list.
5. To insert picture, select Insert, then Picture, from the clip art collection copy any picture.
6. To use word art, select Insert->Picture->Word art. Type the name of the company in word art
7. First type the title of the advertisement & format it using above steps.
8. Type the name of the Designation, qualifications and vacancies as Heading.
9. Now the advertisement is ready for printing.
10. Save the file.
11. Close the document.



Sample Output

                  [image: j0301252]

#120,Old Mahabalipuram Road, Thuraipakkam, Chennai 600 119,Tamil Nadu, INDIA
Ph: +91.44.24962444 / +91.44.24917065 Fax: +91.44.24932444
	Posts
	Total no of requirements for the post
	Experience

	Senior Architect
	5
	                8+

	Software Developer
	10
	                2+





                                                                                                                                                                                                                            














Ex.No. 1.b 
Text Justification, Bullets and numbering  and Spell Checking
Aim :
	To perform Text justification, Spell checking, Bold, Underline, Italics using bullets and numbering in Microsoft word and save the document with suitable name.
Procedure:
1. To create a document , select File menu bar then choose New option
2. For justification, select the text to be justified in the document and then press the Justify button in the formatted tool bar.
3. For Bold face of the word, select the text to change them into bold face in the document and then press the button B in the formatted tool bar.
4. For changing the text style into Italic, select the word and then press the button I in the tool bar.
5. For changing the text style into Underline, select the word and then press the button U in the tool bar.
6. For spelling correction and grammar checking, select the word to be spell corrected, and then click ABC button on the standard tool bar.
7. Click Format->Bullets and Numbering.
8. Now the bullets and numbering dialog box appears.Choose the appropriate bullet Style from the dialog box.
9. Save the file 
10. Close the document.


Sample Output

Bullets and Numbering
The Sought after companies by students during placement interview are 

	Infosys Technologies
Google
Microsoft Technologies
Tata Consultancy Solutions
Cognizant Technology Solutions                        
Wipro Technologies
Patni 
Hexaware Solutions



















Ex.No. 1.c
Text Manipulation with Scientific Notations.
Aim :
	To perform Text manipulation with scientific notations in Microsoft word and save the document with suitable name.
Procedure:
1. To create a document , select File menu bar then choose New option
2. Enter the mathematical equation in the document

X=

	

              Enter the Chemical equation in the document
 				
			


3. Select the character which you want to show as subscript, and choose the font option from the Format menu and enable the subscript check box from the Font dialog
4. For Superscript ,Choose the font option from the Format menu and enable the superscript check box from the Font dialog
5. For changing case, Select change case from format menu .Select the different cases from the selected text.
6. Save the file and quit MS Word.



Sample Output 
Mathematical equation

(a+b)3=a3+3a2b+3ab2+b3
 Chemical equation
C6H12O6+6O2→6Co2+6H2O
















Ex.No. 2
Table Creation and Table Manipulation
Aim :
	To  create a Class Time Table in Microsoft word by inserting rows and columns, merge rows and columns and split columns into cells and save the document with suitable name.
Procedure:
1. To create a document , select File menu bar then choose New option
2. Select Table Option from the menu bar and Choose insert table option.
3. Set number of columns and number of rows in the insert table dialog box and click ok. The table will be created with the specified number of rows and columns.
4. Enter the time table details in the table 
5. To insert a row or column right slick on the table and select row or column.
6. To format the table, right click  select table properties and format the table
7. For merging, select the columns to be merged, and select merge cell option from the Table menu
8. For splitting the table, select the row in which the table is to be split and choose Split table option in the Table Menu. Click on it.
9. Now the table will split into two tables.
10. Converting Text  to table
a. Select the text in the document
b. Choose the convert-text to table from the table menu
c. Choose the table size and separator text option from the convert to table dialog box
d. Now the text information is converted into table


Sample Output

Class Time Table
	DAY
	1
	2
	3
	4
	
LUNCH
	6
	7
	8

	MONDAY
	CY2111
	GE2116
	
	MA2111
	GE2116
	GE2115

	TUESDAY
	GE2111
	GE2116
	
	CY2111
	GE2112

	WEDNESDAY
	GE2112
	PH2111
	
	HS2111

	THURSDAY
	GE2115
	PH2111
	GE2115
	PH2111
	
	GE2116
	CY2111
	MA2111

	FRIDAY
	GE2116
	GE2115
	
	CY2111
	PH2111
	PH2111



Text to table
	Item
	Quantity
	Description

	1.
	1
	Super Computer

	2.
	3
	PC 

	3.
	5
	LCD Monitors

	4.
	8
	120 GB Hard disk Drive

	5.
	4
	Acrobat Reader                     




















Ex.No. 3
Mail Merge and Letter Preparation
Aim :
	To  prepare a call letter to invite students for graduation day using mail merge function
Algorithm:
1. Open a new document.
2. In Tool menu, Go to Letter and Mailing and then choose mail merge.
3. In Document type, Select letter and then go to starting document.
4. In select recipients, Click and  type a new list and then  click create.
5. Enter the address information on the address fields and save the document.
6. Click the write your letter field and type From block and Body of the letter.
7. For entering the address ,click more items and select necessary address fields from the insert merge field.
8. Click preview your letter and complete the merge.
9. Select edit individual letters and then click ok.
10. Save the document
11. Exit Word.
   
    Sample Output: 
      
     From
The Director 
St.Joseph’s College Of Engineering
Chennai – 600 119

To
   2010 Batch Students
  St.Joseph’s College Of Engineering
  Chennai – 600 119

Dear Student,
	We are pleased to inform you that you have been awarded B.E./ B.Tech  degree for the convocation held by Anna University. The formal award will be conferred on you at the convocation which is to be held in our college on 15th March 2010, at 2.00 p.m.
	You are requested to attend the convocation and take the degree certificate. On Behalf of the  Chairman, Principal and all staff members  I wish everyone and would like to meet you on this memorable day.
	  											        Yours, 
                                                                                                                                                                                  Director
	











  
From
      The Director 
      IGCE		
      Trichy

To
   2010 Batch Students
   IGCE		
   Trichy

Dear Student,
	We are pleased to inform you that you have been awarded B.E./ B.Tech  degree for the convocation held by Anna University. The formal award will be conferred on you at the convocation which is to be held in our college on 15th march 2010, at 2.00 p.m.
	You are requested to attend the convocation and take the degree certificate. On behalf of our Chairman, Principal and all staff members I wish everyone and would like to meet you on this memorable day.
	  
Yours 
Director
	  


































    Ex.No. 4
Drawing-Flow Chart
    Aim :
	To  create a document to draw flowchart for 
· Largest of three numbers
· Roots of the quadratic equation

     Procedure :
1. To create a document , select File menu bar then choose New option
2. Choose the flowchart option in the auto shapes menu from the drawing tool bar
3. Select the flowchart symbols from auto shapes
Start / Terminate

Input

Process

Loop / Preparation
      
Flow Lines / Arrows

			
							       Decision

							       Connector
							

4. After finishing the entire flowchart select all the flowchart symbols and arrows ,right click and click   Grouping.
5. Save the document


















Sample Output


Flow chart to find the largest of 3 numbers




[image: ]























A flowchart for computing the roots of a quadric equation, given the coefficients A, B, and C




[image: ]




















Ex.No. 5.a
Generate Line Chart using Ms Excel
     Aim :
	To generate a line chart for a cricket match over by over in Microsoft Excel and save with suitable name.
Procedure :
11. To create a Workbook , select File menu bar then choose New option
12. Enter the runs scored in over 1 to 5.Select the table and choose Insert->Chart
13. Now a Chart Wizard dialog will be displayed.
14. Chart Wizard Shows different kinds of charts and graphs. Select Line Chart and select sub type then click Next 
15. Select the series in rows or columns. Then select columns.
16. In X axis type Over and in Y axis type Runs
17. Click Finish
18. Now a line chart of a cricket score over by over will be generated in the workbook.

Output:   
	Over
	Runs

	1
	4

	2
	10

	3
	6

	4
	11

	5
	8



[image: ]











Ex.No. 5.b
Generate Bar Chart using Ms Excel
     Aim :
	To generate a bar chart for students mark list in Microsoft Excel and save with suitable name.
Procedure :
1. To create a Workbook , select File menu bar then choose New option
2. Type the student marks for five subjects .Select the table and choose Insert->Chart
3. Now a Chart Wizard dialog will be displayed.
4. Chart Wizard Shows different kinds of charts and graphs. Select Bar Chart and select sub type then click Next 
5. Select the series in rows or columns. Then select columns.
6. Make the X axis in the chart as marks and Y axis as student names
7. Click Finish
8. Now a Bar chart of a student mark list will be generated in the workbook.

      Output:   
       
Bar Chart
	Name
	mark1
	mark2
	mark3
	mark4

	Anand
	89
	56
	45
	78

	Arun
	15
	23
	26
	45

	Aswin
	78
	89
	65
	45

	Bharth
	11
	32
	22
	55

	Balaji
	78
	48
	68
	52



[image: ]




















Ex.No. 5.c
Generate Pie Chart using Ms Excel
     Aim :
	To generate a pie chart for utilization of hard disk space in Microsoft Excel and save with suitable name.
Procedure :
1. To Create a Workbook , select File menu bar then choose New option
2. Type the utilization of drives for three drives namely C,D,E, of a 100 Gigabyte hard drive .Select the table and choose Insert->Chart
3. Now a Chart Wizard dialog will be displayed.
4. Chart Wizard Shows different kinds of charts and graphs. Select pie Chart and select sub type then click Next 
5. ,Enable the labels value and percentage in the chart data Labels
6. Click Finish
7. Now a Bar chart of Hard disk utilization will be generated in the workbook.


         Output: 
Pie chart
	Drive
	Util

	C
	50

	D
	30

	E
	10

	Unpartitioned
	10


 

[image: ]













Ex.No. 5.d
Generate XY Chart using Ms Excel
     Aim :
	To generate a XY chart for comparing a company product sales in Microsoft Excel and save with suitable name.
Procedure :
1. To create a Workbook , select File menu bar then choose New option
2. Type the product sales for every month  .Select the table and choose Insert->Chart
3. Now a Chart Wizard dialog will be displayed.
4. Chart Wizard Shows different kinds of charts and graph’s. Select XY Chart and select sub type then click Next 
5. In the chart data Labels ,Enable the labels value and percentage
6. Click Finish
7. Now a XY chart of product sales will be generated in the workbook.

Output:
		
                                               XY Chart
	Product
	1st Quarter
	2nd Quarter
	3rd Quarter
	4th Quarter

	product1
	200
	485
	1457
	456

	product2
	635
	854
	415
	145

	product3
	147
	256
	458
	254



[image: ]















Ex.No. 6.a
Formula Editor using Ms Excel
	Aim :
		To create a student mark details work sheet using  Microsoft Excel and save with suitable name.
	Procedure:
1. To create a Workbook , select File menu bar then choose New option
2. Enter the marks obtained by students in subjects
3. Calculate the total using the formula =SUM(m1,m2…mn).
4. Calculate the average using the formula =AVERAGE(m1,m2…mn).
5. Calculate the grade using the formula IF(Avg>90,A,IF(Avg>80,B,IF(Avg>70,C, IF(Avg>60F))).
6. Apply the filter option from Data→Filter

             Output:   
      
	Si.No
	Name
	physics
	chemistry
	maths
	Total
	Average
	Grade

	1
	Arvind
	70
	80
	60
	210
	70
	C

	2
	Balu
	85
	50
	95
	230
	76.333
	C

	3
	Chandru
	80
	52
	88
	200
	66.6667
	F

	4
	Diwakar
	95
	100
	80
	275
	91.6667
	A

	5
	Elizebath
	45
	55
	85
	165
	61.6667
	F


	






































Ex.No. 6.b
			NUMBER CONVERSION
	Aim:
		To create a conversion between different number formats in work sheet.
	Procedure:
1. To create a Workbook , select File menu bar then choose New option
             2. For Converting 
· Decimal to Binary
·  DEC2BIN (number,places) convert decimal to binary number.
· Decimal to Octal
·  DEC2OCT (number,places) convert decimal to Octal number.
· Decimal to HexaDecimal
·  DEC2HEX(number,places) convert decimal to Hexadecimal number.
· Rupees to Dollar
·  DOLLAR(number,places) convert rupees to dollar value.
· Dollar to Rupees
· DOLLARFR (number,places) convert dollar to rupees value.

           Output:   

	Decimal
	Binary

	30
	1110

	Decimal
	Octal

	45
	55

	Decimal
	Hexa decimal

	440
	1B8

	Rupees
	Dollar

	5500
	114.58$

	Dollar
	Rupees

	$40.00
	1920


























Ex.No. 7
Inclusion of object, Picture, Clipart and Protect the document
     Aim :
	To include object, picture and graphics in a workbook and also protect the workbook.
Procedure :
1. For Creating a Workbook , select File menu bar then choose New option
2. Inclusion Of Object
a. Choose Object option from Insert Menu.
b. Choose Bitmap Image option from list of objects shown
c. It shows all the tools necessary for Bitmap Object
d. Draw a image in the Bit map object
e. Place the Bitmap picture in the excel workbook
3. Insertion Of Picture
a. Choose Picture option from the Insert menu
b. Choose file option
c. Now choose the picture to be inserted in the worksheet from the picture Dialog Box
d. Insert the Picture in the worksheet
4. Insertion Of clipart
a. Choose ClipArt option from the Insert menu
b. Choose  All collection option
c. Now choose the Clipart to be inserted in the worksheet from the Clipart window
d. Insert the Clipart in the worksheet
5. Protecting the Document
a. In the data menu, Click protection→protect sheet
b. Type the password and confirm password and click ok to protect the document.
c. To accesss the workbook type the same password and edit.

Output:   
Login:Javid Ali.L
Picture						Clipart	
[image: Blue%20hills]                [image: j0304933]	

      Insert Object

Bitmap Image			
			
Protecting Worksheet
	[image: ]

[image: ]

































EX.No: 8		
SORTING, IMPORT AND EXPORT FEATURES
Aim:
To implement the sorting, import and export features in excel sheet using  Microsoft Excel and save with suitable name.
Procedure:	
1. To create a Workbook , select File menu bar then choose New option
2. Enter the student mark details
3. Calculate the total using the formula =SUM(m1,m2…mn).
4. Calculate the average using the formula =AVERAGE(m1,m2…mn).
5. Enter the student mark details and select it and click data→sort.
6. Type the student mark details in notepad and save it.
7. In excel sheet, click
a.  Data→Import External Data→Import data.
8. Select the data source, Text import wizard appears.
9. In Text import wizard, select the delimiter to separate the data and click finish.
10. Now the data will be imported in the excel sheet.
Output:
	Name
	physics
	chemistry
	Maths

	Arun
	56
	52
	14

	Balaji
	78
	56
	98

	chandru
	25
	52
	65

	Donald
	99
	98
	99

	Edwin
	12
	32
	45



Before Sorting
	Name
	physics
	chemistry
	maths

	Edwin
	12
	32
	45

	Chandru
	25
	52
	65

	Arun
	56
	52
	14

	Bala
	78
	56
	98

	Donald
	99
	98
	99


																				






After Sorting                    

              
               



Imported             
	Total
	Average
	Grade

	122
	40.66667
	F

	232
	77.33333
	C

	142
	47.33333
	F

	296
	98.66667
	A

	89
	29.66667
	F


















Ex.No 9a
				Area Of Circle

AIM:
	To write a C program to calculate area of a circle.
ALGORITHM:

Step-1 Start the program.
Step-2	Input the radius of the circle.
Step-3	Calculate the area of the circle using the formula 
			Area=3.14*r*r
	Step-4	Print the area of the circle
Step-5	Stop 


PROGRAM: 

/*TO FIND THE AREA OF THE CIRCLE*/
	
	#include<stdio.h>
	main()
	{
		float r,area,;
		printf(“\nEnter the radius of the circle”);
		scanf(“%f”,&r);
		area=3.14*r*r;
		printf(“\nArea=%f”,area);
	}


OUTPUT:



Enter the radius of the circle
4
Area = 50.24
 















Ex.No 9b
Temperature Conversion
AIM:
	To write a C program for temperature conversion from Celsius to Fahrenheit and vice versa.
ALGORITHM:

Step-1 Start the program.
Step-2	 Input the celsius and fahrenheit values 
Step-3	 Calculate the temperature from Celsius to Fahrenheit using the formula
			F= (1.8*c)+32
Step-4	 Calculate the temperature from Fahrenheit to Celsius using the formula
		              C=5/9(F-32)
Step-5	 Print the calculated values
Step-6	 Stop 


PROGRAM: 

/*TO CONVERT THE TEMPERATURE FROM CELSIUS TO FAHREHEIT AND VICE VERSA*/
	
	#include<stdio.h>
	main()
	{
		float cel, fah ,c ,f;
clrscr();
		printf(“\nEnter the fahrenheit value:”);
		scanf(“%f”,&f);
cel=(5.0/9.0)*(f-32);
printf(“Celsius=%d”,cel);
printf(“\nEnter the Celsius value:”);
		scanf(“%f”,&c);
fah=(9.0/5.0)*c+32;
printf(“Fahrenheit=%d”,fah);
getch();
	}


OUTPUT:


Enter the fahrenheit value:8
Celsius = -13.33 
Enter the celsius value:10
Fahrenheit = 50








Ex.No 9c

Evaluate the given Expression
AIM:
	To write a C program to evaluate the given expression
ALGORITHM:

Step-1  Start the program.
Step-2  Input the values for declared variables
Step-3	  Substitute the values in expression and calculate the results.
Step-4  Print the results
Step-5	  Stop 


PROGRAM: 
 
	/* Expression Evaluation*/

#include<stdio.h>
main()
{
	int a,b,c;
             float x,y,z;
	printf ("Enter the values for a,b,c \n");
	scanf("%d,%d,%d", &a,&b,&c);
	x = (a * b) – c;
             y = (b/c) * a;
             z = (a - b) / (c + d)
             printf(" The value of x is “,x ”the value of y is “,y ”The value of z is “,z );
	
}


OUTPUT:


Enter the value for a,b,c.
a= 5; b = 6; c= 12;
x =  28.000;
y = 2.5000
z = 0.0555 














Ex.No 9d

Find the Given year is Lear Year or Not (using if else)
AIM:
	To write a C program to find a given year is leap year or not

ALGORITHM:

Step-1 Start the program.
Step-2	Enter the year value
Step-3	Divide the entered year by 4.If there is no remainder it is a leap year else not a leap year.
Step-4	Print the result
Step-5	Stop 



PROGRAM: 

 	/* Check for Leap Year*/

#include<stdio.h>
main()
{
	int year;
	printf ("Enter the year \n");
	scanf("%d", &year);
	if (year%4==0)
	   printf("It is a Leap Year \n");
	else
	   printf("It is Not a Leap Year\n");
}




OUTPUT:

Enter the year 2004
It is a Leap Year
Enter the year 1998
It is not a Leap Year









Ex.No 9e

      Largest of three numbers (using if elseif else)
AIM:
	To write a C program for finding largest of three given numbers.
ALGORITHM:

Step-1 	Start the program.
Step-2	Input the three integer values A,B,C.
Step-3	Check 
1. If  the no A is greater than the other two no’s B and C
If so , Print A is largest
2. Elseif the second no B is greater than the third no C	
              If so, Print B is Largest
3. Else  Print  C is largest
Step-4	Print the result
Step-5	Stop 

PROGRAM: 

/*To Find the Largest of 3 Nos*/
	
	#include<stdio.h>
#include<conio.h>
	main()
	{
	int a,b,c;
	clrscr();
	printf(“Biggest of three No’s”);
	printf(“Enter the values of A,B,C”);
	scanf(“%d%d%d”,&a,&b,&c);
	if((a>b)&&(b>c))
printf(“\n a=%d is greatest”,a);
elseif(b>c)
{
printf(“\n b=%d is greatest”,b);
}
else
{
printf(“\n c=%d is greatest”,c);
}
getch();
	}

OUTPUT:


Enter the values of A,B,C:10  20 5
B = 20  is greatest







Ex.No 9f
             Age - Height Evaluation
AIM:
	To write a C program to determine the height of a child whose age is in the range of 2 to 5.
ALGORITHM:
 	Step -1    Start the program
	Step -2     Enter the child’s age and height
	Step -3     Determine
(i) If the age is in the range of 2 – 3  determine
1. If the height is less than 55 report short
2. If the height is in between 55 to 75 report normal
3. Otherwise report tall 
(ii) If the age is in the range of 4 – 5  determine
1. If the height is less than 75 report short
2. If the height is in between 75 to 100 report normal
3. Otherwise report tall 
Step -4       Stop
PROGRAM: 
/* Program for evaluating age and height of children in 2 to 5 age group */
#include<stdio.h>
#include<conio.h>
main()
	{
	int age,height;
	clrscr();
	printf("\n Enter the age (in the range of 2 - 5 )and height ");
	scanf("%d%d",&age,&height);
	if(age<4)
		{
		if(height<55)
		  printf("\n the height is short");
		else if((height >=55)&&(height < 75))
		  printf("\n the height is normal");
		else
		  printf("\n the height is tall");
		}
	else
		{
		if(height<75)
		  printf("\n the height is short");
		else if((height >=75)&&(height < 100))
		  printf("\n the height is normal");
		else
		  printf("\n the height is tall");
		}
		getch();
	}







OUTPUT:

Enter the age (in the range of 2 – 5) and height :
2
65
the height is normal

Enter the age (in the range of 2 – 5) and height :
5
120
the height is tall







































Ex.No 9g

Find the Given no is palindrome or Not
AIM:
	 To find sum of Digits, Reverse and the given Number is Palindrome or not.

ALGORITHM:
	Step-1	Start the program
	Step-2	Enter the number
	Step-3	Set a loop upto the number is not equal to zero
	Step-4	Find the digit of the number
	Step-5	Find the reverse of that number
Step-6	Find  whether the reverse number is equal to the given number. If equal the number is palindrome else its not a palindrome
Step-7 Stop	

 PROGRAM:

   /* PROGRAM TO FIND THE REVERSE OF THE GIVEN NUMBER*/
#include<stdio.h>
main()
{
	unsigned long int a, num, r_ num=0,rem;
	printf(“\nEnter the number”);
	scanf(“%ld”,&num);
	a=num;
	while(num!=0)
	{
		rem=num%10;
		r_ num=r_ num*10+rem;
		num=num/10;
	}
		printf(“\nThe reverse number of the %ld is %ld”,a,r_ num);
	if(a==r_ num)
		printf(“\nThe given number is a palindrome”);
	else
		printf(“\nThe given number is not a palindrome”);
}

OUTPUT:

Enter the number...22322
The reverse number of the 22322 is 22322
The given number is a palindrome
Enter the number...12322
The reverse number of the 12322 is 22321
The given number is not a palindrome








Ex.No 9h
Generation of Armstrong Numbers

AIM:
           To write a C program for generating Armstrong numbers between 1 to 1000 numbers.

ALGORITHM:

	Step-1	Start the program
	Step-2	Enter the number up yo which Armstrong numbers are to be generated.
	Step-3	Set a loop upto the number 
	Step-4	Sum the cube of each individual digit of the number and store the sum in s.
            Step-5	Check whether the entered digit and calculated sum are equal.
Step-6	Find whether the reverse number is equal to the given number. If equal the number is Armstrong else not an Armstrong number
Step-7 Increment the loop and perform steps 5 and 6 till the end of loop is reached.
Step-8 Stop.

      
PROGRAM: 
                                /*Program to find armstrong number between 1 to N*/ 
#include<stdio.h>
main()
{
int number, temp, digit1, digit2, digit3;
printf("Printing all Armstrong numbers between 1 and 500:\n\n");
number = 001;
while (number <= 500)
{
digit1 = number - ((number / 10) * 10);
digit2 = (number / 10) - ((number / 100) * 10);
digit3 = (number / 100) - ((number / 1000) * 10);
temp = (digit1*digit1*digit1) + (digit2*digit2*digit2) + (digit3*digit3*digit3);
if (temp == number)
{
printf("\nAmstrong Number:%d", temp);
}
number++;
}
}

OUTPUT: 

Enter the number up to which Armstrong numbers are to be generated:
500
Armstrong numbers are : 1,153,370,371,407






Ex.No 9i
Multiplication of two matrices (Using For Loop)

AIM:
	 To write a program to multiply two matrixes.

ALGORITHM:

Step-1	Start the program
Step-2	Enter the number of rows and columns of matrix A 
Step-3	Enter the number of rows and columns of matrix B 
Step-4	Enter the values of the A and B matrices
Step-5	Display the entered values of A and B in matrix format
Step-6	Set a loop up to row
Step-7	Set a inner loop up to column
Step-8 Set another inner loop up to column
Step-9	Multiply the A and B matrix and store the element in the C matrix
Step-10 Display the resultant matrix.
Step-11 Stop

PROGRAM:
/* MULTPLICATION OF TWO MATRIX*/
#include<stdio.h>
main()
{
	int a[15][15],b[15][15],c[15][15],i,j,k,r,s;
	int m,n;
	printf(“\nEnter the Rows and Columns of A matrix...”);
	scanf(“%d %d”,&m,&n);
	printf(“\nEnter the Rows and Columns of B matrix...”);
	scanf(“%d %d”,&r,&s);
	if(m!=r)
		printf(“\nMatrix multiplication cannot be performed”);
	else
	{
		printf(“\nEnter the elements of A matrix”);
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			scanf(“\t%d”,&a[i][j]);
		}
		printf(“\nEnter the elements of B matrix”);
		for(i=0;i<m;i++)
		{
			for(j=0;j<n;j++)
			scanf(“\t%d”,&b[i][j]);
		}
		printf(“\nThe elements of A matrix”);
		for(i=0;i<m;i++)
		{
			printf(“\n”);
			for(j=0;j<n;j++)
			printf(“\t%d”,a[i][j]);
		}
		printf(“\n The elements of B matrix”);
		for(i=0;i<m;i++)
		{
			printf(“\n”);
			for(j=0;j<n;j++)
			printf(“\t%d”,b[i][j]);
		}
		for(i=0;i<m;i++)
		{
			printf(“\n”);
			for(j=0;j<n;j++)
			{
				c[i][j]=0;
				for(k=0;k<m;k++)
				c[i][j]=c[i][j]+a[i][k]*b[k][j];
			}
		}
	}
	printf(“The multiplication of two matrixes”);
	for(i=0;i<m;i++)
	{
		printf(“\n”);
		for(j=0;j<n;j++)
		printf(“\t%d”,c[i][j]);
	}
}

INPUT AND OUTPUT 

Enter the Rows and Columns of A matrix... 3 3
Enter the Rows and Columns of B matrix... 3 3
Enter the elements of A matrix 2 4 6 8 9 10 11 12 13
Enter the elements of B matrix 1 3 5 7 9 11 13 15 17 
The elements of A matrix
	2	4	6	
	8	9	10	
	11	12	13
The elements of B matrix
	1	3	5
	7           9           11
	13         15         17
The multiplication of two matrixes
	108       132       156	
	201       255       309	
	264       336       408






Ex.No.9j.
Demonstrate Arithmetic Operations (Using Switch…Case)

AIM:
        To write a C program for demonstrating arithmetic operations using switch case statement.

ALGORITHM:

Step-1	Start the program
Step-2	Display menu showing addition, subtraction, multiplication and division operation. 
Step-3	Get the values for two variables
Step-4	Obtain the choice from the user and accordingly switch over to particular block.
Step-5	Display the result.
Step-6	If the user wishes to continue repeat steps 2 and 3
Step-7	Stop


PROGRAM:

/* Program to demonstrate arithmetic operations */

#include<stdio.h>
#include<conio.h>
void main()
{
     int a, b, c, n;
     clrscr();
     printf(“1. Addition\n”);
     printf(“2. Subtraction\n”);
     printf(“3. Multiplication\n”);
     printf(“4. Division\n”);
     printf(“0. Exit\n”);
     printf(“Enter your choice  : “);
     scanf(“%d”,&n);
     printf(“Enter the two numbers  :”);
     scanf(“%d,%d”,&a,&b);
     switch(n)
   {

       case 1:
                  c = a + b;
      printf(“Addition   :%d\n”,c);
      break;
       case 2:
                 c = a – b;
                 printf(“Subtraction    :%d\n”,c);
                 break;
       case 3:
                  c = a * b;
                 printf(“Multiplication    :%d\n”,c);
                 break;
      case 4:
                 c = a / b;
                 printf(“Division    :%d\n”,c);
                 break;
      case  0:
                 exit(0);
                 break;
}


     getch();
}



OUTPUT:


          1. Addition
          2. Subtraction
          3. Multiplication
          4. Division
          0. Exit

Enter Your Choice :  1
Enter the 2 nos a and b:   2    8
Addition : 10.

Enter Your Choice :  2

Enter the 2 nos a and b:   5    2
Subtraction : 3.

Enter Your Choice :   3
Enter the 2 nos a and b:   2    8
Multiplication : 16.

Enter Your Choice : 4.
Enter the 2 nos a and b:   8    4
Division : 2.

Enter Your Choice :  0.
Exit.










Ex.No 10
Generating Pascal triangle using Array

AIM:
		To write a C program to generate pascal triangleusing array.
ALGORITHM:
            Step-1	Start the program
            Step-2	Enter the no of lines from the user and accordingly create an array. 
Step-3	Declare two variables one for outer rows and the other for inner rows.
Step-4	Check that if (j==0||i==j), display a[i][j]=1  or else display the consecutive integer      Step-5	Display the triangle.
Step-6	Stop.
.
PROGRAM:
/* Pascal Triangle */

#include<Stdio.h> 
#include<conio.h> 
void main() 
{ 

int a[20][20], i ,j ,n, s=25, k; 
            printf("\n enter the number of lines:"); 
            scanf("%d", &n); 
            for(i=0;i<n; i++) //outer loop for rows 
              for(k=s-2*i; k>=0;k--) 
               printf(" "); 
  	for(j=0;j<=i;j++) //inner loop for columns 
            {  
               if(j==0||i==j) 
      a[i][j]=1; 
   else 
      a[i][j]=a[i-1][j-1]+a[i-1][j]; 
 printf("%4d",a[i][j]); 
             printf("\n"); 
            } 
    getch(); 
}

OUTPUT:

Enter the number of lines:6

                            1
                          1   1
                        1   2   1
                      1   3   3   1
                    1   4   6   4   1
                  1   5  10  10   5   1
                





Ex.No 11a
EMPLOYEE PAYROLL USING STRUCTURE

AIM:
	To write a c program to generate employee payroll using structures.
ALGORITHM:

Step-1	Start the program
            Step-2	Create a Structure named Employee containing records Id,name, Basic Salary, Net 
                        Salary, HRA, DA and Tax. 
Step-3	Get the employee Id and retrieve his details.
Step-4	Using the basic salary, DA, HRA, Tax calculate tax and net salary
Step-5	Display the details each employee record containing name, number, basic salary, 
            HRA, DA, Net Salary and Tax
Step-6	Stop.


PROGRAM:

/* Calculate Employee salary using Structures*/
#include<stdio.h>
#include<conio.h>
struct employee
{
         char name[15];
         int empid;
         float bsal;
         float nsal;
         float gross;
};
void main()
{
     struct employee emp;
     float hra,da,tax;
     clrscr();
     printf("\nEmployee Details");
     printf("\nEnter the employee name");
     scanf("%s",emp.name);
     printf("\nEnter the employee id");
     scanf("%d",&emp.empid);
     printf("\nEnter the basic salary");
     scanf("%f",&emp.bsal);
     hra=((10*emp.bsal)/100);
     da=((35*emp.bsal)/100);
     tax=((15*emp.bsal)/100);
     emp.gross=emp.bsal+hra+da;
     emp.net=emp.gross-tax;
     printf("\nEmployee name:%s",emp.name);
     printf("\nEmployee no:%d",emp.empid);
     printf("\nEmployee Basic salary:%f",emp.bsal);
     printf("\nHRA:%f",hra);
     printf("\nDA:%f",da);
     printf("\nTax:%f",tax);
     printf("\nNetSalary%f",emp.nsal);
     printf("\nGross salary:%f",emp.gross);
     getch();
}


OUTPUT:

Employee Details:
Enter the employee name : Robin
Enter the employee Id       : 100
Enter the basic salary        : 30000

Employee name            : Robin
Employee Id                  : 100
Employee Basic salary : 30000.000000
HRA                               : 3000.000000
DA                                  : 10,500.000000
Tax		          : 4500.000000
Gross salary   	          : 39000.000000


































Ex.No 11.b
Student Marks using Union
AIM:
To write a program to print the student name, roll no, average mark and their grades.

ALGORITHM:

Step-1	Start the program
Step-2	Initialize the union variable  
Step-3	Enter the number of student
Step-4	Set a loop up to the number of student
Step-5	Enter the student name, roll no, average marks
Step-6	Find their grades
Step-7	Print the student name, roll no, average and their grade
Step-9	Stop
	
PROGRAM:

/*Student marks using union*/
#include<stdio.h>
main()
{
	union student
	{
		char name[20];
		char regno[12];
		int avg;
		char grade;
	} stud[25],*ptr;
	int i,no;
	printf(“Enter the number of the students...”);
	scanf(“%d”,&no);
	for(i=0;i<no;i++)
	{
		printf(“\n student[%d]  information:\n”,i+1);
	printf(“Enter the name”);
	scanf(“%s”,stud[i].name);
	printf(“\nEnter the roll no of the student”);
	scanf(“%s”,stud[i].regno);
	printf(“\nEnter the average value of the student”);
	scanf(“%d”,&stud[i].avg);
	}
	pt=stud;
	for(pt=stud;pt<stud+no;ptr++)
	{
		if(ptr->avg<30)
			ptr->grade=’D’;
		else if(ptr->avg<50)
			ptr->grade=’C’;
		else if(ptr->avg<70)
			ptr->grade=’B’;
		else
			ptr->grade=’A’;
	}
	printf(“\n”);
	printf(“NAME REGISTER-NO AVERAGE GRADE\n”);
	for(ptr=stud;ptr<stud+no;pt++)
	{
		printf(“%-20s%-10s”,ptr->name,ptr->regno);
		printf(“%10d \t   %c\n”,ptr->avg,ptr->grade);
	}
}

OUTPUT:



Enter the number of the students 
3
student[1]  information:
Enter the name Jack
Enter the roll no of the student 31705205001
Enter the average value of the student 90
student[2]  information:
Enter the name Raj
Enter the roll no of the student 31705205002
Enter the average value of the student 88
student[3]  information:
Enter the name Kiran
Enter the roll no of the student 31705205003
Enter the average value of the student 75

NAME	    REGISTER-NO	AVERAGE	GRADE 
Jack	     31705205001	     90		   S
Raj	     31705205002	      88		   A			
Kiran         31705205003	      75		   B

















Ex.No 12.a

Swapping Two Numbers (Using Call By Value)
AIM:
	To write a C program to swap two numbers without using third variable using call by value.
ALGORITHM:
 	Step -1   Start the program
	Step -2   Enter the two numbers
	Step -3   Call the swap function
Step -4   Add the second number with the first number
Step -5   Subtract the second number from the first number and assign the value to the 
               Second number
Step -6   Subtract the second number from the first number and assign the value to the
               First number
Step -7   Stop	 

PROGRAM:
/* Swapping 2 Nos without 3rd variable using call by value*/
#include<stdio.h>
#include<conio.h>
main()
	{
	 int n1,n2;
	 void swap(int ,int);
	 clrscr();
	 printf("\n Enter the two numbers");
	 scanf("%d%d",&n1,&n2);
	 printf("\n Before swapping the values of n1 = %d and n2 = %d",n1,n2);
	 swap(n1,n2);
	 getch();
	}
void swap(int a,int b)
	{
		a=a+b;
		b=a-b;
		a=a-b;
	       printf("\n After swapping the values of n1 = %d and n2 = %d",a,b);

}


OUTPUT:

Enter the two numbers
5
10
Before swapping the values of n1 =5 and n2 =10
After swapping the values of n1 =10 and n2 = 5







Ex.No 12.b
Swapping Two Numbers Using Call be Reference
AIM:
	To write a C program to swap two numbers using call by reference.
ALGORITHM:
 	Step -1    Start the program
	Step -2     Enter the two numbers
	Step -3     Call the swap function using the address of the numbers as arguments
Step -4      Assign the address of  the first number to a temporary variable
Step -5      Assign the address of the second number to the first number
Step -6      Assign the value of the temporary variable to the first number
Step -7      Stop	 

PROGRAM :
/* Swapping 2 Nos using call by reference */
#include<stdio.h>
#include<conio.h>
main()
	{
	  int n1,n2;
	  void swap(int *,int *);
	  clrscr();
	  printf("\n Enter the two numbers");
	  scanf("%d%d",&n1,&n2);
	  printf("\n Before swapping the value of n1= %d and n2= %d",n1,n2);
	  swap(&n1,&n2);
	  printf("\n After swapping the value of n1= %d and n2= %d",n1,n2);
	  getch();
	}
void swap(int *a,int *b)
	{
	int t;
	t = *a;
	*a = *b;
	*b = t;
	}


OUTPUT:

Enter the two numbers
5
10
Before swapping the value of n1 = 5 and n2 = 10
After swapping the value of n1 = 10 and n2 = 5








Ex.No 12.c
         
 Factorial Computation using recursive Function

AIM:
	To write a program to find the factorial of the given number using recursion

ALGORITHM:

Step-1	Start the program
Step-2	Enter the number
Step-3  Call the recursive function passing the number to the recursive function as an argument.
Step-4  If the entered number is equal to one then return one to main function.
Step-5	If the number is less greater then one then call recursive
Step-6	Print the factorial value of the number.
Step-7	Stop

PROGRAM:

/* Factorial using recursion*/
#include<stdio.h>
main()
{
	int num,a;
	printf(“Enter the number”);
	scanf(“%d”,&num);
	a=recur(num);
	printf(“The factorial of the number %d is %d”,num,a);
}
recur(int no)
{
	int fact=1;
	if(no==1)
		return(1);
else
	fact=no*recur(no-1);
}

OUTPUT:


Enter the number 5
The factorial of the number 5 is 120
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